We Have Had An Error Error 500

0

Hello, I have an error while installing the laravel app, firstly the link opened sbm.optikaas.com/install I followed the steps by entering the database name that I've created the username and pass, and then I had an error sql prompting it could not found the table optikaas_bm.users, then i checked the database where the table was created with the name tec_users and all the other tables had the same prefix tec_. I removed the prfixes in each table the installation completed but then the error appeared ERROR 500.

I checked the error_log it was clear, I also checked storage_logs . I added the log in attachment i think a file named settings.json is missing. but anyways i hope to hear from you asap.

P.S all the versions meet the required ones.

Attachments
Question Resolved For: Simple Business Manager - Invoicing Solution 0 Votes 5 Answers 139 Views
Asked by Gent 3 months ago

0

Answered by Mian Saleem

Hello,

Have you downloaded the file recently? As I remember the prefix and settings file issues were fixed 😦

Not sure about removing the prefix. If there is any issue later, you can set the prefix int the config/database.php

You can create storage/app/settings.json with following contents

{
    "demo": false,
    "stock": false,
    "ac": {
        "rows": "25",
        "sideBarStyle": "1",
        "dateformat": "DD\/MM\/YYYY",
        "noRows": "10",
        "idColumn": true,
        "navPosition": "left",
        "short_name": "SBM",
        "select": false,
        "country": {
            "value": "BD",
            "label": "Bangladesh"
        }
    },
    "baseURL": "http:\/\/sbm.test",
    "app": {
        "name": "Business Manager"
    },
    "system": {
        "card_gateway": null,
        "default_account_id": null
    }
}

Thank you

0

Answered by Gent 2 months ago

i bough it last year and i downloaded the file like 3 days ago, maybe that file didn't get updated like the rest of the newer bought files anyways i made the changes and now its working fine, one last question, at the invoice and while creating customers in the state area i don't see the capital city of my country Macedonia, i only see other cities located in that country where can i add the missing cities ?

0

Answered by Gent 2 months ago

i also get this error in email templates 500 Internal Server Error ill send u log in attachment.

0

Answered by Mian Saleem 2 months ago

Hello,

I used menarasolutions/geographer-laravel for the countries and cities.

The helpers were removed after v6 and I recently updated to Laravel 8 and missed this. I will fix this soon.

Thank you

We use Cookies

We use cookies to ensure that we give you the best experience on our website. By continuing to browse the site you are agreeing to our use of cookies.