Install Frontend Npm Dependencies Error

0

Hi [@Mian Saleem](/u/saleem) It has been awhile, trust you're doing great.
Please any idea why I am getting the errors below?

PS C:\laragon\www\pos> npm run mps:i
npm ERR! Missing script: "mps:i"
npm ERR! 
npm ERR! Did you mean one of these?
npm ERR!     npm run mps:u # run the "mps:u" package script
npm ERR!     npm run mps:h # run the "mps:h" package script
npm ERR!     npm run mps:p # run the "mps:p" package script
npm ERR! 
npm ERR! To see a list of scripts, run:
npm ERR!   npm run

npm ERR! A complete log of this run can be found in: C:\Users\gifte\AppData\Local\npm-cache\_logs\2023-05-02T11_59_17_226Z-debug-0.log
PS C:\laragon\www\pos> 
Question Resolved For: Modern Point of Sale Solution 0 Votes 2 Answers 354 Views
Asked by Enyinnaya Gift 1 year ago

0

Answered by Enyinnaya Gift 1 year ago

Is there a difference between a Regular license from CodeCanyon and a Standard license HERE? The reason I am asking is because in the documentation in the Developer Guide section, on What's Included, you stated that the regular license doesn't come with front-end (Vue), feature tests, database migrations, or seed files, but are all included in the standard or extended license... It is a bit confusing; please explain.

0

Answered by Mian Saleem 1 year ago

Hello,

The individual install commands were removed. Please run npm install && npm run installAll then you should be able to run prod, mps:p, mps:h, shop:p and shop:h commands.

No difference, the standard license here is eqivlant to regular license on codecanyon.net

The Basic license here doesn't come with front-end source code. Other's all do. I will update the docs.

Thank you

We use Cookies

We use cookies to ensure that we give you the best experience on our website. By continuing to browse the site you are agreeing to our use of cookies.